Six Apart‘s Strange Bug Fixing Method

Recently it became known that there is a bug in one of Movable Type‘s scripts allowing spammers to use it as an e-mail gateway. The good news is that the cude people at Six Apart have already released a modified version of the script fixing that hole.

The bad news is, that they chose to replace the script in the release 2.64 of Movable Type. Why don‘t they increase the version number? I mean, that‘s what version numbers are for. When somebody reads about this bug later and just checks that the latest release (which fixes the bug) is 2.64 and he looks at his installation and sees it is 2.64 as well, why should he bother re-installing “the same” stuff again? I‘d like to see

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.